Powershell 3.0 valmis

Natuke hiljaks jäänud, aga väärib siiski mainimist, et Windows Management Framework 3.0 (sealhulgas Powershell 3.0) on nüüd valmis ka Windows 7, Server 2008 R2 ja Server 2008 jaoks.

Paigaldus eeldab, et masinas on olemas .NET Framework 4.0 (Extended, mitte Client Profile).  Ilma selleta teatab paigaldus, et ei saa ennast masinasse panna (põhjust ei täpsustata).

Kui Powershelli uuendamiseks on põhjust vaja, siis ainuüksi Powershell ISE on nii palju intelligentsem, et tasub järeleproovimist.

Kõik 2.0 jaoks kirjutatud skriptid peaksid edasi töötama.  Probleeme võib tulla moodulitega (näiteks Hyper-V moodul), eriti kui need on isekirjutatud ning mooduliga imporditavate käskude nimed ei arvesta  soovitatud tegusõnade loendiga (mida saab käsurealt näha Powershelli käsuga Get-Verb).  Powershell 2.0 hoiatas mooduli laadimisel, et tegu on ebasoovitatava käsunimega, aga Powershell 3.0 moodulite automaatne laadimine ja näiteks käsk Get-Command võivad selle peale katki minna.  Moodulite automaatlaadimisega võib ka kergemini juhtuda, et erinevate moodulite samanimelised käsud hakkavad teineteist segama.

Tasub tähele panna, et hulk uusi käske, mis on Windows 8 ja Server 2012-ga kaasas, ei ole Powershell 3.0 osa, vaid on seotud OS-versiooniga.  Nii et neid käske varasematesse OS-versioonidesse ei saa.

Advertisements